Webhook Status Update Delay

Incident Report for RevoEngine (RevoNG)

Postmortem

Summary:

We experienced a delay in our Webhook processing infrastructure, affecting the status updates of Webhooks.

Impact:

All Webhooks were processed as expected; however, they remained in the "CREATED" state for 3 hours.

Resolution:

The issue has been identified and resolved. We apologize for any inconvenience this may have caused.

Next Steps:

We are implementing measures to prevent future occurrences and improve our monitoring systems to detect and address such issues more swiftly.

Posted May 22, 2024 - 13:01 UTC

Resolved

Our Webhook processing infrastructure had delay with updating status of Webhooks, all of the Webhooks were processed as normally, but they were stuck in "CREATED" state for 3 hours.
Posted May 22, 2024 - 06:30 UTC